Workast Help Center

Search for answers to your questions by entering keywords below, or look through our knowledge base.

System Requirements and Supported Browsers

At Workast, we mirror the list of browsers supported by Slack which can be found here.   Please note that as of March 2019*, Slack will be changing its minimum browser requirements.  As Workast uses the sign-on with Slack login function, Workast minimum browser requirements will also change at that time.

Current browser requirements:

  • Chrome - version 51 and newer
  • Firefox - version 47 and newer
  • Safari - 9 and newer
  • Internet Explorer - 11
  • Edge - Version 31 and newer

Future requirements (expected update as of March, 2019)

  • Chrome - version 66 and newer
  • Firefox - version 52 and newer
  • Safari - 10.1 and newer
  • Internet Explorer - no longer supported
  • Edge - Version 41 and newer

Operating system requirements

  • Mac - OS X 10.9 or later
  • Windows - Windows 7 or later
  • Linux - Ubuntu LTS releases 16.04 or later (beta)
  • Linux - Fedora 26 or later (beta)
  • Linux - Red Hat Enterprise Linux 7.0 or later (beta)
  • iOS - iOS 10.0 or later
  • Android - Android 4.4 or later

* anticipated date, subject to change

Was this article helpful?
0 out of 0 found this helpful

Comments